Jump to content
World's Largest Herpes Support Group
Just existing

Aciclovir not working

    Recommended Posts

    Just existing

    I recently post that I have HSV1 on my genitals. I'm done with my viral medication but the lesions are still there. I'm not sure if it's still herpes. The first single sore now looks like a rash on the side of my vulva. Whenever I'm looking at it my vaginal opening has white discharge. I think that since the lesion is on the "moist" part, it's not healing. And aciclovir didn't heal it. I had it three times a day for 10 days. I'm trying to see it using mirror and now it's hurting. I don't know what to do. Any advice? Thank You so much. 

    Share this post


    Link to post
    Share on other sites
    ANewSelf

    Have you been back to the doctor??

    I just started on acyclovir, too.  

    Share this post


    Link to post
    Share on other sites

    Advertisement

    doh!

    Acyclovir usually needs to be taken 5 times a day, not 3, in the case of outbreaks.
    " It has poor bioavailability of about 20% and a short half life, which necessitates frequent dosing. "
    Have you tried valacyclovir? Or another doctor?

    Edited by adiebear
    more info

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    Advertisement

    Try a Lysine supplement for cold sores

    ×